<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://denver.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="%tags%" />
<meta name="keywords" content="colorado news, colorado weather" />
<meta property="fb:pages" content="52552983299" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee &#8211; CBS Denver</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Denver &raquo; Feed" href="https://denver.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Denver &raquo; Comments Feed" href="https://denver.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Denver &raquo; I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee Comments Feed" href="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://denver.cbslocal.com/_static/??-eJytj00OAiEMhS8kNi7EsDCehYE6kikt4Sdef5Bx40oncdX2td/LKzyTcsIVuUJ9YMQCbiqKxFmCwI6af0mlwF2kYj729gA/QRgn9BubMpJY/x1O1ObABaL4Rn1j3wa97ofHgYqW7Yx52HwoqodcqqQdL20eLU5sAykKvPw/FVKfuI5/b/F6OuuLNkYbvQJ18J9x' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://denver.cbslocal.com/_static/??-eJyNy1EOQDAMgOELmSJGPIizTDVIulrSirg9u4B4/fP9cCWHhxiJgW0USQFndXxgYFC7mUpULeCL7YJ8LjmpQgorOaOYONiPNy/EbxTTrKc41r5vq6HxnX8AIdc5IA==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://denver.cbslocal.com/_static/??-eJydUtFOwzAM/CG8dIMBL4hvcVKvC03qKHFX+vekLd00imDdQ6SL4zufHasugOFGqBElR/KUlNEJHBt0Kri2sk1SnsvW5ZcxATw2WFFUJuVIH+hpk9GD+kvINsa15RDKnM6WBEI+OBRKK8kBo9zA+ek8HTmK4Vnlcl1RnrymcuKPEJxNAgYFHVcr28hdWOMITsvhzdbzEawiejgQlZNtDZfoDgrYbbxtzgpXFcpsTulcus4+dcTYqyS9oyvGzfPLf1aRnP9vwAsR38JM+yAJaOoF/YCGNPNgqc7g89vSHUrCAQKnjH6XuGOXPcZ6kJ7yDTuOd2zaf7p8othFK6Pld/+23b88Pr8W22L/BSxMVQQ=' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-external-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-8' href='https://denver.cbslocal.com/wp-content/mu-plugins/jetpack/css/jetpack.css?m=1573161115g' type='text/css' media='all' />
<script type='text/javascript' src='https://denver.cbslocal.com/_static/??-eJy1kNEOwiAMRX9IxGkW44PxWxA67CxljjLj34vLHvTJzcSnQrn39FJ975SNLMCi5QIBkrbnpChaQxrZUnal1SbdRXo0SLQOyOs2rfRcYzvL0VH2yEmH6DKVF+NGcylq2L4TPtC3DP1jKl8FKqDvjcBPeUaBCoaNh/6F/mioMu8qsVu0mCazFYyc/hEIqNxY0qJExl0g4TBvQ0XvKZ4NLRvRC1qCxd+9o/MgI2I6FsQpHKt6X20OVV3v2id14wp2'></script>
<link rel='https://api.w.org/' href='https://denver.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://denver.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://denver.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.4" />
<link rel='shortlink' href='https://cbsloc.al/37Rb0be' />
<link rel="alternate" type="application/json+oembed" href="https://denver.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdenver.cbslocal.com%2F2019%2F11%2F29%2Frock-slide-westbound-interstate-70-genesee%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://denver.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdenver.cbslocal.com%2F2019%2F11%2F29%2Frock-slide-westbound-interstate-70-genesee%2F&#038;format=xml" />
			<meta property="fb:pages" content="" />
			
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee" /><meta property="og:image" content="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/05/web-road-closures-1200x675.jpg?w=1200" /><meta property="og:image:secure_url" content="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/05/web-road-closures-1200x675.jpg?w=1200" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:description" content="The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook." /><meta property="og:type" content="article" /><meta property="og:url" content="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/" /><meta property="article:published_time" content="2019-11-29T10:00:49+00:00" /><meta property="article:suggested-social-copy" content="The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook." /><meta property="article:publisher" content="http://www.facebook.com/cbsdenver" /><meta property="article:author" content="http://www.facebook.com/cbsdenver" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/05/web-road-closures-1200x675.jpg?w=1200"><meta name="twitter:title" content="I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee"/><meta name="twitter:description" content="The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook."/><meta name="twitter:site" content="/CBSdenver"/>
<link rel="canonical" href="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
						<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/denver.cbslocal.com","url":"https:\/\/denver.cbslocal.com","name":"CBS Denver","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/cbsdenver.com","logo":{"@type":"ImageObject","url":"https:\/\/denver.cbslocal.com\/wp-content\/uploads\/sites\/15909806\/2018\/02\/3_denver_cbs4.png?w=230"}},"url":"https:\/\/denver.cbslocal.com\/2019\/11\/29\/rock-slide-westbound-interstate-70-genesee\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/denver.cbslocal.com\/2019\/11\/29\/rock-slide-westbound-interstate-70-genesee\/"},"headline":"I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee","description":"The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook.","image":"https:\/\/denver.cbslocal.com\/wp-content\/uploads\/sites\/15909806\/2019\/05\/web-road-closures-1200x675.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Home Page","Local","News","Syndicated Local","Weather Blog","Colorado News","Colorado Weather","news","I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee"],"datePublished":"2019-11-29T10:00:49+00:00","dateModified":"2019-11-29T10:00:49+00:00","author":{"@type":"Organization","name":"CBSDenver"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script>
<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.DENVER","news",["i70closurerockslideshutsdownwestboundi70neargenesee","post","article","homepage","local","news","syndicatedlocal","weatherblog","coloradonews","coloradoweather","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<script type="text/javascript">
			var formatTracker,marketTracker,masterTracker,stationsTracker,rollupTracker,pageTracker;
			var cbs_evidon_noticecdn_id = "https:\/\/denver.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/425";
			var cbs_evidon_noticecdn_sitenotice = "https:\/\/denver.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/";
		</script>
		<script type="text/javascript">(function(id){
			function append(scriptid,url,async){var d=document,sn='script',f=d.getElementsByTagName(sn)[0];if(!f)f=d.head;var s=d.createElement(sn);s.async=!0;s.id=scriptid;s.src=url;f.parentNode.insertBefore(s,f)}
			function getRootDomain(){return 'cbslocal';}
			window.evidon={};window.evidon.id=id;
			var evidoncdn='//c.evidon.com/',cdn="https:\/\/denver.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/",rootDomain='cbslocal',noticecdn=cbs_evidon_noticecdn_sitenotice;
			append('evidon-notice',cbs_evidon_noticecdn_sitenotice+'evidon-sitenotice-tag.js',!1);
			append('evidon-location',evidoncdn+'geo/country.js',!0);
			append('evidon-themes',cbs_evidon_noticecdn_id+'/snthemes.js',!0);
			append('evidon-settings',cbs_evidon_noticecdn_id+'/cbslocal/settings.js',!0);
			window.evidon.priorConsentCallback=function(){
				cbs_j.log('[CPM] priorConsentCallback');
				cbs_j.function_queue("partners-header-js", 'cbs_partners_header_js');
				cbs_j.function_queue("partners-footer-js", 'cbs_partners_footer_js');
			}
		})(425)</script>
		<link rel="icon" href="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/07/cropped-denver-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/07/cropped-denver-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/07/cropped-denver-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/07/cropped-denver-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook." />
<script>//<![CDATA[
		!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://untidyrice.com/v2/0/jxhqDExjnT9bCW5Dzq0djz0BD7BFCoMweZHxeg-6xZw4B0c_4ICMsNeG9iCko2r4kgapvPod27I",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;;
	
function cbs_partners_header_js(){cbs_j.log('[PARTNER] Header Function');cbs_j.dom.load_script("dfp", "//www.googletagservices.com/tag/js/gpt.js");cbs_j.dom.load_script("trak-ga", "https://ssl.google-analytics.com/ga.js");cbs_j.dom.load_script("addthis", "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ddd05dc24272928");cbs_j.dom.load_script("sharethrough", "//native.sharethrough.com/assets/tag.js");cbs_j.dom.load_script("taboola-pixel", "//cdn.taboola.com/libtrc/cbslocal-sc/tfa.js", function() {window._tfa = window._tfa || []; _tfa.push({ notify: "action",name: "page_view" });});}cbs_j.function_queue.activate_point('partners-header-js');
//]]></script>

</head>

<body class="post-template-default single single-post postid-1814355 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://denver.cbslocal.com" id="header-logo"><img src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2018/02/3_denver_cbs4.png?w=230" alt="CBS Denver" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/sports/denver-broncos/" title="Denver Broncos" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Denver Broncos</strong></div></a><a href="https://denver.cbslocal.com/category/sports/denver-nuggets/" title="Denver Nuggets" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Denver Nuggets</strong></div></a><a href="https://denver.cbslocal.com/category/sports/colorado-rockies/" title="Colorado Rockies" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Colorado Rockies</strong></div></a><a href="https://denver.cbslocal.com/category/sports/colorado-avalanche/" title="Colorado Avalanche" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Colorado Avalanche</strong></div></a><a href="https://denver.cbslocal.com/category/sports/xfinity-monday-live/" title="Xfinity Monday Live" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Xfinity Monday Live</strong></div></a><a href="https://denver.cbslocal.com/cbssportshq/" title="CBS Sports HQ" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS Sports HQ</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More &gt;</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><a href="http://denver.cbslocal.com/category/contests/" title="Latest Contests" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Latest Contests</strong></div></a><a href="https://denver.cbslocal.com/station/cbs4/" title="CBS4 News Team" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS4 News Team</strong></div></a><a href="http://denver.cbslocal.com/program-guide/" title="CBS4 Program Guide" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CBS4 Program Guide</strong></div></a><a href="http://denver.cbslocal.com/category/sponsored-events/" title="CBS4 Sponsored Events" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">CBS4 Sponsored Events</strong></div></a><a href="http://denver.cbslocal.com/future-leaders/" title="CBS4 Future Leaders" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">CBS4 Future Leaders</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/video/">Videos</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/video/4224573-cbs4-news-update-11-29-19/" title="CBS4 News Update, 11-29-19" class="cbs-thumbnail-link item-1575038880 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/AAA/6B6/AAA6B6EAFE1B42E0A6393F2A451AD592_4.jpg?Expires=1669659635&#038;KeyName=mcpkey1&#038;Signature=AYb6BA-c5RvY-sDAuixJKV7ybcg"></span></div><div class="title-wrapper"><strong class="title">CBS4 News Update, 11-29-19</strong><em class="description">CBS4 is Colorado&#039;s News Channel</em></div><time datetime="2019-11-29T14:48:00+00:00" title="November 29, 2019 at 7:48 am">4 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224563-morning-fog-afternoon-rain-snow-mix-overnight-wind/" title="Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind" class="cbs-thumbnail-link item-1575036660 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/C57/18E/C5718E50C76546AE82991619A111B78E.jpg?Expires=1669659635&#038;KeyName=mcpkey1&#038;Signature=WaxQ26EJaapBYOc0O55JWjaS0pY"></span></div><div class="title-wrapper"><strong class="title">Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind</strong><em class="description">Watch Ashton Altieri&#039;s forecast.</em></div><time datetime="2019-11-29T14:11:00+00:00" title="November 29, 2019 at 7:11 am">4 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224420-jeffco-public-schools-needs-volunteers-to-help-clear-snow-off-stadium-seats/" title="Jeffco Public Schools Needs Volunteers To Help Clear Snow Off Stadium Seats" class="cbs-thumbnail-link item-1575005300 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/AB1/72C/AB172C0A68784A30AD1A1323A4124A14.jpg?Expires=1669659635&#038;KeyName=mcpkey1&#038;Signature=0BAy7wFsawWpnzsRi3Ec2w1pZqg"></span></div><div class="title-wrapper"><strong class="title">Jeffco Public Schools Needs Volunteers To Help Clear Snow Off Stadium Seats</strong><em class="description">Jeffco Public Schools is asking for help to clear the snow off of the stands ahead of three state semifinal games on Friday and Saturday.</em></div><time datetime="2019-11-29T05:28:20+00:00" title="November 28, 2019 at 10:28 pm">13 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224419-photographer-looking-for-family-in-picture-with-big-boy/" title="Photographer Looking For Family In Picture With &#039;Big Boy&#039;" class="cbs-thumbnail-link item-1575005221 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/5F3/8B7/5F38B7A66088405284E18DF8CBAEFD64.jpg?Expires=1669659635&#038;KeyName=mcpkey1&#038;Signature=JwX7TaYPaZtlC8hz7S2DxLj-N2g"></span></div><div class="title-wrapper"><strong class="title">Photographer Looking For Family In Picture With &#039;Big Boy&#039;</strong><em class="description">A Colorado photographer is asking for help tracking down a family. Kristin Allen was out Monday taking pictures of the historic steam engine known as &quot;Big Boy.&quot;</em></div><time datetime="2019-11-29T05:27:01+00:00" title="November 28, 2019 at 10:27 pm">13 hours ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://denver.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://denver.cbslocal.com/category/news/">Covering Colorado First</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://denver.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://denver.cbslocal.com/news-tips/" title="News Tips" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">News Tips</strong></div></a><a href="https://denver.cbslocal.com/category/trending/" title="Trending" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Trending</strong></div></a><a href="http://denver.cbslocal.com/category/news/investigates/" title="CBS4 Investigates" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CBS4 Investigates</strong></div></a><a href="https://denver.cbslocal.com/category/news/politics/" title="Politics" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://denver.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="http://denver.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://denver.cbslocal.com/category/news/links-info/" title="Links &amp; Info" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Links &amp; Info</strong></div></a><a href="https://denver.cbslocal.com/together4coloradotoydrive/" title="Toy Drive" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Toy Drive</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://denver.cbslocal.com/category/news/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/2019/11/29/adams-county-deputy-ois-shooting-bennett-watkins/" title="Adams County Deputy Shoots, Kills Suspect Near Watkins" class="cbs-thumbnail-link item-1575050438 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/i-70-rockslide-via-matt-kroschel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Adams County Deputy Shoots, Kills Suspect Near Watkins</strong><em class="description">A spokesperson for the Adams County Sheriff&#039;s Office confirmed Friday morning that a deputy has fired shots at a person. </em></div></a><a href="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/" title="I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee" class="cbs-thumbnail-link item-1575046849 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/05/web-road-closures-1200x675.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee</strong><em class="description">The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/photo-galleries/category/news/">News Photos</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/photo-galleries/2019/11/26/thanksgiving-week-snowstorm-2019/" title="Thanksgiving Week Snowstorm 2019" class="cbs-thumbnail-link item-1574782587 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Deer-in-Conifer-credit-Stacie-Allison-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Thanksgiving Week Snowstorm 2019</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/news-tips/">News Tips</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/news-tips/" title="Send CBS4 A News Tip" class="cbs-thumbnail-link item-1568319769" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2016/08/news-tips.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Send CBS4 A News Tip</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://denver.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://denver.cbslocal.com/category/weather/">Denver Weather</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://denver.cbslocal.com/cams/" title="CBS4 Cams" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBS4 Cams</strong></div></a><a href="https://denver.cbslocal.com/cbs4weatherwatchers/" title="Weather Watchers" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather Watchers</strong></div></a><a href="https://denver.cbslocal.com/youreportform/" title="Share Photos" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="http://denver.cbslocal.com/school-closings/" title="School Closings" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">School Closings</strong></div></a><a href="http://apps.cbslocal.com/weather/denver/" title="CBS Denver Weather App" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">CBS Denver Weather App</strong></div></a><a href="https://denver.cbslocal.com/video/program/796/" title="Weather Visits" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather Visits</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Watch Forecast</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/video/4224563-morning-fog-afternoon-rain-snow-mix-overnight-wind/" title="Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind" class="cbs-thumbnail-link item-1575036660 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/C57/18E/C5718E50C76546AE82991619A111B78E.jpg?Expires=1669659669&#038;KeyName=mcpkey1&#038;Signature=z7HEgVkQSWnBdP64GzFfz-9q-Vg"></span></div><div class="title-wrapper"><strong class="title">Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind</strong><em class="description">Watch Ashton Altieri&#039;s forecast.</em></div><time datetime="2019-11-29T14:11:00+00:00" title="November 29, 2019 at 7:11 am">4 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/category/weather-blog/">Colorado's Weather Center</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/2019/11/29/rock-slide-westbound-interstate-70-genesee/" title="I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee" class="cbs-thumbnail-link item-1575046849 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/05/web-road-closures-1200x675.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee</strong><em class="description">The rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook.</em></div></a><a href="https://denver.cbslocal.com/2019/11/29/denver-weather-next-storm-brings-limited-snow-lots-of-wind/" title="Denver Weather: Latest Storm Brings Limited Snow, Lots Of Wind!" class="cbs-thumbnail-link item-1575040234 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/4-14.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Denver Weather: Latest Storm Brings Limited Snow, Lots Of Wind!</strong><em class="description">A slow moving storm will crawl across Colorado Friday and Saturday causing fog Friday morning, a rain/snow mix Friday afternoon, and very strong winds Friday night and Saturday.</em></div></a><a href="https://denver.cbslocal.com/2019/11/28/moving-snow-boulder-airport/" title="Moving Snow: Boulder Hauls Tons Of Snow To Airport" class="cbs-thumbnail-link item-1574966694 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/MOVING-SNOW-5PKG.transfer_frame_1164.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Moving Snow: Boulder Hauls Tons Of Snow To Airport</strong><em class="description">Public Works said it had hauled 320 tons of snow to the Boulder Municipal Airport -- and that was before crews got to the side streets.</em></div></a><a href="https://denver.cbslocal.com/2019/11/27/cold-weather-christkindl-market/" title="Cold Weather Can&#039;t Stop Christkindl Market" class="cbs-thumbnail-link item-1574915636 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/COLD-CHRISTKINDLMARKET-10PKG.transfer_frame_995.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Cold Weather Can&#039;t Stop Christkindl Market</strong><em class="description">With the snow cleared from the sidewalks and temperatures well below freezing, the Denver Christkindl Market was still buzzing with activity.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://denver.cbslocal.com/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://denver.cbslocal.com/category/sports/denver-broncos/">Broncos</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/sports/denver-broncos/" title="Latest Stories" class="cbs-thumbnail-link item-1566401470" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/08/broncos.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Latest Stories</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-5 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://denver.cbslocal.com/sports/">Latest Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/2019/11/27/nuggets-fans-line-up-for-new-city-edition-jerseys/" title="Nuggets Fans Line Up For New &#039;City Edition&#039; Jerseys" class="cbs-thumbnail-link item-1574911720 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/NUGGETS-JERSEYS-ON-SALE-6VO.transfer_frame_184.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Nuggets Fans Line Up For New &#039;City Edition&#039; Jerseys</strong><em class="description">The Nuggets will wear these jerseys seven times this season, starting next Tuesday versus the Los Angeles Lakers.</em></div></a><a href="https://denver.cbslocal.com/2019/11/27/broncos-quarterback-drew-lock-reps-upped-extensively/" title="Broncos Quarterback Drew Lock&#039;s Reps Being &#039;Upped Extensively&#039;" class="cbs-thumbnail-link item-1574887564 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/1112-LOCK-4.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Broncos Quarterback Drew Lock&#039;s Reps Being &#039;Upped Extensively&#039;</strong><em class="description">Drew Lock will see an increased work load in practice this week as the Broncos prepare to host the Chargers.</em></div></a><a href="https://denver.cbslocal.com/2019/11/27/nuggets-defeat-wizards-sixth-consecutive-win/" title="Nuggets Keep Rolling, Defeat Wizards At Pepsi Center" class="cbs-thumbnail-link item-1574874358 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/GettyImages-1190305231.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Nuggets Keep Rolling, Defeat Wizards At Pepsi Center</strong><em class="description">Nikola Jokic had a season-high 20 rebounds and Jerami Grant added a season-best 20 points to lead the Denver Nuggets to a 117-104 win over the Washington Wizards.</em></div></a><a href="https://denver.cbslocal.com/2019/11/24/du-pioneers-together-4-colorado-toy-drive/" title="DU Pioneers Call On Fans To Help Together 4 Colorado Toy Drive" class="cbs-thumbnail-link item-1574873439 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/DU-Collection-.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">DU Pioneers Call On Fans To Help Together 4 Colorado Toy Drive</strong><em class="description">The University of Denver Pioneers are collecting new toys for the Together 4 Colorado Toy Drive.</em></div></a><a href="https://denver.cbslocal.com/2019/11/26/steve-atwater-john-lynch-pro-football-hall-fame-denver-broncos/" title="Steve Atwater, John Lynch Named Semifinalists For Pro Football Hall Of Fame" class="cbs-thumbnail-link item-1574837264 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2016/01/safeties2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Steve Atwater, John Lynch Named Semifinalists For Pro Football Hall Of Fame</strong><em class="description">Safeties John Lynch and Steve Atwater are the two former Broncos are among 25 semifinalists for the Pro Football Hall of Fame Class of 2020.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://denver.cbslocal.com/category/top-spots/" title="Top Spots" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://denver.cbslocal.com/category/top-spots/">Top Spots Around Denver</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/2019/11/28/design-some-new-ink-at-one-of-these-aurora-tattoo-shops/" title="Design Some New Ink At One Of These Aurora Tattoo Shops" class="cbs-thumbnail-link item-1574942422 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Harbour-Lights-Social-Club-credit-Stephanie-S.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Design Some New Ink At One Of These Aurora Tattoo Shops</strong><em class="description">These Aurora shops offer creative, colorful tattoos.</em></div></a><a href="https://denver.cbslocal.com/2019/11/27/these-lodo-favorites-serve-up-delectable-treats/" title="These LoDo Favorites Serve Up Delectable Treats" class="cbs-thumbnail-link item-1574856041 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Rioja-credit-Melissa-M.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">These LoDo Favorites Serve Up Delectable Treats</strong><em class="description">3 LoDo favorites offer up some of the most inspirational meals in the city.</em></div></a><a href="https://denver.cbslocal.com/2019/11/26/shake-up-your-workout-at-these-aurora-favorites/" title="Shake Up Your Workout At These Aurora Favorites" class="cbs-thumbnail-link item-1574769610 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Fly-Kickbox-credit-Trang-L.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Shake Up Your Workout At These Aurora Favorites</strong><em class="description">Ready to change up your workout routine? Check out these spots in Aurora.</em></div></a><a href="https://denver.cbslocal.com/2019/11/25/satisfy-your-craving-for-greek-cuisine-in-aurora/" title="Satisfy Your Craving For Greek Cuisine In Aurora" class="cbs-thumbnail-link item-1574683205 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Athenian-Restaurant-credit-Stella-M.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Satisfy Your Craving For Greek Cuisine In Aurora</strong><em class="description">From gyros to hummus, get your Greek on at one of these Aurora restaurants.</em></div></a><a href="https://denver.cbslocal.com/2019/11/24/peace-out-at-the-denver-meditation-centers/" title="Peace Out At These Denver Meditation Centers" class="cbs-thumbnail-link item-1574648721 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Kundalini-Yoga-credit-Rich-W.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Peace Out At These Denver Meditation Centers</strong><em class="description">Find your zen by slowing down at one of these popular meditation spots in Denver.</em></div></a><a href="https://denver.cbslocal.com/2019/11/23/find-an-eclectic-assortment-of-flavors-in-denvers-montclair-neighborhood/" title="Find An Eclectic Assortment Of Flavors In Denver&#039;s Montclair Neighborhood" class="cbs-thumbnail-link item-1574562648 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Little-Dragon-credit-Mimi-C.-Yelp.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Find An Eclectic Assortment Of Flavors In Denver&#039;s Montclair Neighborhood</strong><em class="description">Denver&#039;s Montclair neighborhood serves up a wide variety of ethnic tastes.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://denver.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/video/4224563-morning-fog-afternoon-rain-snow-mix-overnight-wind/" title="Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind" class="cbs-thumbnail-link item-1575036660 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/C57/18E/C5718E50C76546AE82991619A111B78E.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=mSl9vjoaxgFZfwBu3kkdLh4Q-CE"></span></div><div class="title-wrapper"><strong class="title">Morning Fog, Afternoon Rain/Snow Mix, Overnight Wind</strong><em class="description">Watch Ashton Altieri&#039;s forecast.</em></div><time datetime="2019-11-29T14:11:00+00:00" title="November 29, 2019 at 7:11 am">4 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224420-jeffco-public-schools-needs-volunteers-to-help-clear-snow-off-stadium-seats/" title="Jeffco Public Schools Needs Volunteers To Help Clear Snow Off Stadium Seats" class="cbs-thumbnail-link item-1575005300 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/AB1/72C/AB172C0A68784A30AD1A1323A4124A14.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=zLW8Fd4mstWIF3forf5w6YJr9aM"></span></div><div class="title-wrapper"><strong class="title">Jeffco Public Schools Needs Volunteers To Help Clear Snow Off Stadium Seats</strong><em class="description">Jeffco Public Schools is asking for help to clear the snow off of the stands ahead of three state semifinal games on Friday and Saturday.</em></div><time datetime="2019-11-29T05:28:20+00:00" title="November 28, 2019 at 10:28 pm">13 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224419-photographer-looking-for-family-in-picture-with-big-boy/" title="Photographer Looking For Family In Picture With &#039;Big Boy&#039;" class="cbs-thumbnail-link item-1575005221 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/5F3/8B7/5F38B7A66088405284E18DF8CBAEFD64.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=AFM4Z_mvbCJixP6ipginnsH-XBg"></span></div><div class="title-wrapper"><strong class="title">Photographer Looking For Family In Picture With &#039;Big Boy&#039;</strong><em class="description">A Colorado photographer is asking for help tracking down a family. Kristin Allen was out Monday taking pictures of the historic steam engine known as &quot;Big Boy.&quot;</em></div><time datetime="2019-11-29T05:27:01+00:00" title="November 28, 2019 at 10:27 pm">13 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224418-luvin-arms-animal-sanctuary-in-erie-celebrates-thanksgiving-with-rescued-turkeys/" title="Luvin Arms Animal Sanctuary In Erie Celebrates Thanksgiving With Rescued Turkeys" class="cbs-thumbnail-link item-1575005137 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/D63/7A1/D637A1AE18FC43C7A72862D0A71DA9B2.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=q_fLdYsT28Vw4DBmCeIkK5ltTvA"></span></div><div class="title-wrapper"><strong class="title">Luvin Arms Animal Sanctuary In Erie Celebrates Thanksgiving With Rescued Turkeys</strong><em class="description">Instead of eating turkey on Thanksgiving, Luvin Arms Animal Sanctuary in Erie celebrated the holiday alongside rescued turkeys.</em></div><time datetime="2019-11-29T05:25:37+00:00" title="November 28, 2019 at 10:25 pm">13 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224417-salvation-army-now-accepting-digital-donations-were-hoping-this-is-the-answer/" title="Salvation Army Now Accepting Digital Donations: &#039;We&#039;re Hoping This Is The Answer&#039;" class="cbs-thumbnail-link item-1575005060 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/385/58C/38558C3E61A04C1A8781E1DB6CE2F2BE.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=Q-bxRKb8KeYtTQ-2TNTw6SY6ld8"></span></div><div class="title-wrapper"><strong class="title">Salvation Army Now Accepting Digital Donations: &#039;We&#039;re Hoping This Is The Answer&#039;</strong><em class="description">With Christmas just around the corner, the Salvation Army’s Red Kettle Campaign is in full swing.</em></div><time datetime="2019-11-29T05:24:20+00:00" title="November 28, 2019 at 10:24 pm">13 hours ago</time></a><a href="https://denver.cbslocal.com/video/4224416-we-could-not-pass-this-up-shoppers-take-advantage-of-early-thanksgiving-deals/" title="&#039;We Could Not Pass This Up&#039;: Shoppers Take Advantage Of Early Thanksgiving Deals" class="cbs-thumbnail-link item-1575004996 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/21F/B0E/21FB0E53E06A458186F66CFAAA0BF785.jpg?Expires=1669659719&#038;KeyName=mcpkey1&#038;Signature=jdVa5X2o9O0Sj_nksOs6V0m-4W0"></span></div><div class="title-wrapper"><strong class="title">&#039;We Could Not Pass This Up&#039;: Shoppers Take Advantage Of Early Thanksgiving Deals</strong><em class="description">Roads still may be snowy in areas of the Denver metro, but that isn’t stopping people from getting a jump on holiday shopping.</em></div><time datetime="2019-11-29T05:23:16+00:00" title="November 28, 2019 at 10:23 pm">13 hours ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="http://denver.cbslocal.com/category/contests/" title="Contests &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More From CBS4</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/learn-about-us/" title="Station Info" class="cbs-thumbnail-link item-1534790811" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2018/08/cbs4-station-logo.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="http://cbsdenver.com/contests/" title="Contests" class="cbs-thumbnail-link item-1534787117" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2018/05/contest.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Contests</strong></div></a><a href="https://denver.cbslocal.com/category/news/links-info/" title="Links &amp; Info" class="cbs-thumbnail-link item-1533134510" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2018/08/links-info1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Links &amp; Info</strong></div></a><a href="http://denver.cbslocal.com/program-guide/" title="CBS4 Program Guide" class="cbs-thumbnail-link item-1520869130" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2018/08/tv-schedule.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS4 Program Guide</strong></div></a><a href="http://denver.cbslocal.com/category/cbs4/sponsored-events/" title="CBS4 Sponsored Events" class="cbs-thumbnail-link item-1520754486" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2017/10/together-4-colorado-events.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS4 Sponsored Events</strong></div></a><a href="http://denver.cbslocal.com/station/cbs4/" title="News Team" class="cbs-thumbnail-link item-1514221514" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2017/12/cbs4-news-team.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News Team</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/watch-cbs4-video-live/" title="CBS4" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS4</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">11:00 AM</strong><em class="description">CBS4 News Special</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">11:30 AM</strong><em class="description">CBS Sports Spectacular</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">12:30 PM</strong><em class="description">College Football</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">4:00 PM</strong><em class="description">Dr. Phil</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">CBS4 News at 5</em></div></div></div>
</div></div><a class="view-all" href="http://denver.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://denver.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.739236" longitude="-104.990251" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://denver.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">I-70 Closure: Rock Slide Shuts Down Westbound I-70 Near Genesee</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">November 29, 2019 at 10:00 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://denver.cbslocal.com/tag/colorado-news/">Colorado News</a>, <a href="https://denver.cbslocal.com/tag/colorado-weather/">Colorado Weather</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4224563&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;DVzl9QRzox3ZZsP9bNu5Li3X7obQOnqP&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;denver.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.DENVER&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/37Rb0be&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5,&quot;recom&quot;:true,&quot;maxRecomPages&quot;:3}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><br />
<html><body><strong>DUMONT, Colo. (CBS4)</strong> &#8212; Interstate 70 westbound is closed just west of Genesee &#8212; from Beaver Brook to Downieville &#8212; due to a rock slide. This is the same area where the <a href="https://denver.cbslocal.com/2019/11/26/rocks-slide-interstate-70-closure-idaho-springs-colorado/">rock slide happened earlier this week</a>. Crews expect us closer to be longer because they will need to do blasting.</p>
<blockquote class="twitter-tweet" data-width="420" data-dnt="true">
<p lang="en" dir="ltr">Can&#39;t get there from here.<br />I-70 into mts closing.<br />It&#39;s closed WB at Beaver Brook on the W side of Evrgrn  right now due2 a new rockslide at Dumont. WB traffic being turned around. EB to close Frisco to Idaho Springs at noon. C-DOT says this is an &quot;all day event.&quot; <a href="https://twitter.com/CBSDenver?ref_src=twsrc%5Etfw">@CBSDenver</a> <a href="https://twitter.com/hashtag/I70?src=hash&amp;ref_src=twsrc%5Etfw">#I70</a> <a href="https://t.co/CJwIKRaBFa">pic.twitter.com/CJwIKRaBFa</a></p>
<p>&mdash; Alan Gionet (@AlanGTV) <a href="https://twitter.com/AlanGTV/status/1200451874526240769?ref_src=twsrc%5Etfw">November 29, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>According to CDOT, the rockfall early Friday has closed both lanes of westbound I-70 at mile marker 248 near Beaver Brook. Westbound drivers are being turned around to head east. US 6 and US 40 are also closed.</p>
<p>&#8220;There is a large overhanging rock that they are trying to secure,&#8221; said Sgt. Blake White with the Colorado State Patrol.</p>
<p>There is no estimated time for the road to reopen.</p>
<div class="fb-video" data-allowfullscreen="true" data-href="https://www.facebook.com/matt.kroschel/videos/3356464454380150?vh=e&#038;d=n&#038;sfns=mo"></div>
<p>The highway will also be closed eastbound from Frisco to Idaho Springs starting about noon Friday. CDOT says drivers should plan ahead and find an alternate route.</p>
<p><a href="https://twitter.com/Matt_Kroschel/status/1200460339969609728" rel="nofollow">https://twitter.com/Matt_Kroschel/status/1200460339969609728</a></body></html></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/37Rb0be"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/37Rb0be"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/37Rb0be"></a></span>
			</div>
		
			</div>
</div></div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/11/29/rock-slide-westbound-interstate-70-genesee/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=162246152&#038;postid=1814355&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=7.9.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=5733562356e13d6b0000dc9ff943c4bf80c9f376#parent=https%3A%2F%2Fdenver.cbslocal.com%2F2019%2F11%2F29%2Frock-slide-westbound-interstate-70-genesee%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

					
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/cbsdenver" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CBSdenver" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/cbs4denver" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.instagram.com/cbsdenver/" target="_blank" title="instagram_url" class="cbs-thumbnail-link instagram_url" ><div class="title-wrapper"><strong class="title">instagram_url</strong></div></a><a href="https://www.reddit.com/user/cbsdenver" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/kcnc-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=denver"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://denver.cbslocal.com/2019/11/28/colorado-springs-boy-shovels-snow/" title="HILARIOUS: Boy Fed Up With Shoveling Snow In Colorado Springs" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/KID-IS-OVER-THE-SNOW-10VO.transfer_frame_641.jpg?resize=55%2C55&#038;ssl=1" alt="HILARIOUS: Boy Fed Up With Shoveling Snow In Colorado Springs" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/28/colorado-springs-boy-shovels-snow/" title="HILARIOUS: Boy Fed Up With Shoveling Snow In Colorado Springs" class="bump-view" data-bump-view="tp">HILARIOUS: Boy Fed Up With Shoveling Snow In Colorado Springs</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/10/03/maria-elena-gimeno-woman-keying-tesla-surveillance-video-broomfield-legacy-high-school/" title="Maria Elena Gimeno, Accused Of Keying Tesla, Turns Herself In To Broomfield Police" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/10/Maria-Elena-Gimeno-suspect.jpg?resize=55%2C55&#038;ssl=1" alt="Maria Elena Gimeno, Accused Of Keying Tesla, Turns Herself In To Broomfield Police" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/10/03/maria-elena-gimeno-woman-keying-tesla-surveillance-video-broomfield-legacy-high-school/" title="Maria Elena Gimeno, Accused Of Keying Tesla, Turns Herself In To Broomfield Police" class="bump-view" data-bump-view="tp">Maria Elena Gimeno, Accused Of Keying Tesla, Turns Herself In To Broomfield Police</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/06/11/coloradans-amazon-delivery-service/" title="&#039;Pretty Big Deal&#039;: Coloradans Take Leap Of Faith To Start Amazon Delivery Service" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/06/amazon-delivery-5pkg.transfer_frame_1605.png?resize=55%2C55&#038;ssl=1" alt="&#039;Pretty Big Deal&#039;: Coloradans Take Leap Of Faith To Start Amazon Delivery Service" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/06/11/coloradans-amazon-delivery-service/" title="&#039;Pretty Big Deal&#039;: Coloradans Take Leap Of Faith To Start Amazon Delivery Service" class="bump-view" data-bump-view="tp">&#039;Pretty Big Deal&#039;: Coloradans Take Leap Of Faith To Start Amazon Delivery Service</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/28/photographer-family-picture-big-boy-train/" title="Photographer Looking For Family In Picture With &#039;Big Boy&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/Big-Boy-photo-Credit-Kristin-Allen.jpg?resize=55%2C55&#038;ssl=1" alt="Photographer Looking For Family In Picture With &#039;Big Boy&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/28/photographer-family-picture-big-boy-train/" title="Photographer Looking For Family In Picture With &#039;Big Boy&#039;" class="bump-view" data-bump-view="tp">Photographer Looking For Family In Picture With &#039;Big Boy&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/28/denver-minimum-wage/" title="Denver Becomes First Colorado City To Set Its Own Minimum Wage" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/06/denver-skyline.jpg?resize=55%2C55&#038;ssl=1" alt="Denver Becomes First Colorado City To Set Its Own Minimum Wage" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/28/denver-minimum-wage/" title="Denver Becomes First Colorado City To Set Its Own Minimum Wage" class="bump-view" data-bump-view="tp">Denver Becomes First Colorado City To Set Its Own Minimum Wage</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/27/wildlife-crossing-elk-stop-traffic-weather-report/" title="Wildlife Crossing: Elk Stop Traffic Right Behind Warning Sign" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/elk-crossing-sign-best.jpg?resize=55%2C55&#038;ssl=1" alt="Wildlife Crossing: Elk Stop Traffic Right Behind Warning Sign" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/27/wildlife-crossing-elk-stop-traffic-weather-report/" title="Wildlife Crossing: Elk Stop Traffic Right Behind Warning Sign" class="bump-view" data-bump-view="tp">Wildlife Crossing: Elk Stop Traffic Right Behind Warning Sign</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/25/horse-tied-pickup-truck-colorado-grand-county-video/" title="Horse Tied, Pulled Behind Truck Sparks Animal Abuse Investigation" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/horse.jpg?resize=55%2C55&#038;ssl=1" alt="Horse Tied, Pulled Behind Truck Sparks Animal Abuse Investigation" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/25/horse-tied-pickup-truck-colorado-grand-county-video/" title="Horse Tied, Pulled Behind Truck Sparks Animal Abuse Investigation" class="bump-view" data-bump-view="tp">Horse Tied, Pulled Behind Truck Sparks Animal Abuse Investigation</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/26/denver-snow-totals-northern-colorado-weather-snowstorm-warning-blizzard/" title="Denver Weather: Storm Moves Away Leaving Frigid Temperatures, Huge Snow Behind" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/2-18.png?resize=55%2C55&#038;ssl=1" alt="Denver Weather: Storm Moves Away Leaving Frigid Temperatures, Huge Snow Behind" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/26/denver-snow-totals-northern-colorado-weather-snowstorm-warning-blizzard/" title="Denver Weather: Storm Moves Away Leaving Frigid Temperatures, Huge Snow Behind" class="bump-view" data-bump-view="tp">Denver Weather: Storm Moves Away Leaving Frigid Temperatures, Huge Snow Behind</a>
							</div>
													</li>
										<li>
						<a href="https://denver.cbslocal.com/2019/11/27/westminster-arrest-parking-lot-standoff/" title="Man Arrested In Parking Lot Standoff With Westminster Police" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/denver.cbslocal.com/wp-content/uploads/sites/15909806/2011/11/police-line-crime-scene-night-lights-tape-generic.jpg?resize=55%2C55&#038;ssl=1" alt="Man Arrested In Parking Lot Standoff With Westminster Police" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://denver.cbslocal.com/2019/11/27/westminster-arrest-parking-lot-standoff/" title="Man Arrested In Parking Lot Standoff With Westminster Police" class="bump-view" data-bump-view="tp">Man Arrested In Parking Lot Standoff With Westminster Police</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://denver.cbslocal.com" class="logo"><img src="https://cbs-local.go-vip.co/wp-content/uploads/sites/15909806/2017/10/denver.png" alt="CBS Denver" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/cbsdenver" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CBSdenver" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/cbs4denver" class="youtube" target="_blank">YouTube</a><a href="https://www.instagram.com/cbsdenver/" class="instagram" target="_blank">Instagram</a><a href="https://www.reddit.com/user/cbsdenver" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/kcnc-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">CBS4 News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://denver.cbslocal.com/show/investigates/" title="CBS4 Investigates" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBS4 Investigates</strong></div></a><a href="https://denver.cbslocal.com/category/news/politics/" title="Politics" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Politics</strong></div></a><a href="https://denver.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="http://denver.cbslocal.com/category/news/business/" title="Business" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="https://denver.cbslocal.com/news-tips/" title="News Tips" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">News Tips</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">CBS4 Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/sports/" title="Colorado Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Colorado Sports</strong></div></a><a href="http://denver.cbslocal.com/category/sports/denver-broncos/" title="Denver Broncos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Denver Broncos</strong></div></a><a href="http://denver.cbslocal.com/category/sports/colorado-rockies/" title="Colorado Rockies" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Colorado Rockies</strong></div></a><a href="http://denver.cbslocal.com/category/sports/denver-nuggets/" title="Denver Nuggets" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Denver Nuggets</strong></div></a><a href="http://denver.cbslocal.com/category/sports/colorado-avalanche/" title="Colorado Avalanche" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Colorado Avalanche</strong></div></a><a href="https://denver.cbslocal.com/category/sports/xfinity-monday-live/" title="Xfinity Monday Live" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Xfinity Monday Live</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Weather</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/category/weather/" title="Denver Weather" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Denver Weather</strong></div></a><a href="http://denver.cbslocal.com/school-closings/" title="Colorado School Closings" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Colorado School Closings</strong></div></a><a href="https://denver.cbslocal.com/cbs4weatherwatchers/" title="CBS4 Weather Watchers" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS4 Weather Watchers</strong></div></a><a href="http://apps.cbslocal.com/weather/denver/" title="CBS Denver Weather App" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CBS Denver Weather App</strong></div></a><a href="https://denver.cbslocal.com/youreportform/" title="Share Photos" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Share Photos</strong></div></a><a href="https://denver.cbslocal.com/video/program/796/" title="Weather Visits" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Weather Visits</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://denver.cbslocal.com/program-guide/" title="TV Schedule" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">TV Schedule</strong></div></a><a href="http://denver.cbslocal.com/category/eat-see-play/" title="Top Spots" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Top Spots</strong></div></a><a href="http://denver.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Station Info</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://denver.cbslocal.com/station/cbs4/" title="CBS4 News Team" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBS4 News Team</strong></div></a><a href="http://denver.cbslocal.com/contact/" title="Contact Us" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a><a href="http://denver.cbslocal.com/category/links-info" title="Links &amp; Info" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Links &amp; Info</strong></div></a><a href="https://denver.cbslocal.com/category/contests/" title="Latest Contests" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Latest Contests</strong></div></a><a href="https://denver.cbslocal.com/category/sponsored-events/" title="Sponsored Events" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Sponsored Events</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://denver.cbslocal.com/learn-about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="https://denver.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cbs.avature.net/cbstvscareers" title="Employment" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Employment</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://denver.cbslocal.com" class="logo"><img src="https://denver.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Denver" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2019 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=denver.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://policies.cbslocal.com/privacy/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-188211" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188211"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-188212" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-188212"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-1367109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1367109"><a href="http://policies.cbslocal.com/privacy/current.html#cali-visitors">Your California Privacy Rights</a></li>
<li id="menu-item-1367113" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1367113"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-387054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-387054"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
<li id="menu-item-1751209" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1751209"><a target="_blank" rel="noopener noreferrer" href="http://publicfiles.fcc.gov/tv-profile/kcnc-tv">Public File for KCNC-TV / CBS4</a></li>
<li id="menu-item-1752855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1752855"><a target="_blank" rel="noopener noreferrer" href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-1754000" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1754000"><a href="https://denver.cbslocal.com/wp-content/uploads/sites/15909806/2019/11/2019-EEO-PUBLIC-FILE-REPORT-DRAFT.docx">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://denver.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://denver.cbslocal.com/_static/??-eJyljFsKgCAQRTeUDWZFP9FadBxK8EUabr8hWkH93de50LLAFCvFCvWgQAXQFOETag8uor8sRxQMWW7KK4V3pfZsO/jOMxeyxl8/jTSvT9Gc3el52sIqp1mpRcpxuAEy2VFu' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://denver.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563381142g' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201948'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://denver.cbslocal.com/_static/??-eJyNjUsKAyEQRC8UpyNBQhYhRwl+eoZ27FZQGZLTR8jG5Swf9aoKjqJ8lobSgLsqqW8kFSK2Yv0ObxIPrlMKsFqPLuddITsMC5MssV7gdD/Z70cR2w1HXGect4afevgrA+evFz+1uevrQxtziz8Su0L9'></script>
<script type='text/javascript' src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1'></script>
<script type='text/javascript' src='https://denver.cbslocal.com/wp-content/mu-plugins/akismet/_inc/form.js?m=1559853160g'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246152&postid=1814355&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5733562356e13d6b0000dc9ff943c4bf80c9f376#parent=https%3A%2F%2Fdenver.cbslocal.com%2F2019%2F11%2F29%2Frock-slide-westbound-interstate-70-genesee%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=162246152&postid=1814355&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=7.9.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=5733562356e13d6b0000dc9ff943c4bf80c9f376#parent=https%3A%2F%2Fdenver.cbslocal.com%2F2019%2F11%2F29%2Frock-slide-westbound-interstate-70-genesee%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201948.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'162246152',post:'1814355',tz:'-7',srv:'denver.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246152', '1814355' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>